Unexpected Phone Issues
Incident Report for Hosting Servers & Network
Resolved
All toll free numbers are working as expected. Thank you again for your patience.
Posted 4 months ago. Jun 29, 2017 - 09:12 EDT
Update
We are continuing to work with our upstream provider on this issue. Again, if you do have problems calling our toll free number you can try the local number or email our support team. Thank you for your continued patience.
Posted 4 months ago. Jun 28, 2017 - 17:00 EDT
Investigating
We are currently experiencing issues with our toll free numbers. This is being worked on as top priority. You can use the local numbers or send an email to our support department if you need assistance. Thank you for your patience.
Posted 4 months ago. Jun 28, 2017 - 10:48 EDT