Downgraded Performance - Phone System
Incident Report for Hosting Servers & Network
Resolved
All phone systems are working properly at this time.
Posted about 1 year ago. Oct 07, 2016 - 12:21 EDT
Monitoring
Our phone provider has corrected the issue. We will continue to monitor to ensure everything is working properly.

Thank you for your patience.
Posted about 1 year ago. Oct 07, 2016 - 10:51 EDT
Investigating
We are currently experiencing intermittent phone issues. We are working with our provider to have these issues resolved as quickly as possible. For any questions or issues please email support.

We will update this post with all updates. Thank you for your patience.
Posted about 1 year ago. Oct 07, 2016 - 09:14 EDT