Degraded Email Performance
Incident Report for Hosting Servers & Network
Resolved
The issue is fixed. Kindly resend the mail that were rejected previously.
Posted almost 2 years ago. Jul 19, 2016 - 16:50 EDT
Investigating
We are currently experiencing degraded email performance for a small number of customers. Our technicians are working on the issue and will update this post when this has been resolved.
Posted almost 2 years ago. Jul 19, 2016 - 16:09 EDT