cPanel service down: In cpanel04.myhostcenter.com
Incident Report for Hosting Servers & Network
Resolved
At this time all services are back up and running. If you are still experiencing any issues please contact our Support Department for further investigation.

Thank you again for your patience.
Posted almost 2 years ago. Jan 22, 2016 - 10:16 EST
Investigating
We are currently investigating on the issue with cPanel of our server cpanel04.myhostcenter.com. We will fix the issue as soon as possible with the help of cPanel support team.

The issues will be resolved soon.

We really apologize for the inconvenience caused.
Posted almost 2 years ago. Jan 22, 2016 - 03:33 EST