cp40-cp44 Temporary downtime
Incident Report for Hosting Servers & Network
Resolved
The issue is resolved and servers are back online.
Posted over 1 year ago. Jun 11, 2016 - 11:10 EDT
Identified
The servers are having load spikes and we are working on it. Thank you for your patience in this matter.
Posted over 1 year ago. Jun 11, 2016 - 09:18 EDT