bhcp02.myhostcenter.com maintenance
Incident Report for Hosting Servers & Network
Resolved
Maintenance on bhcp02.myhostcenter.com has completed. Thank you for your patience.
Posted 11 months ago. Jan 09, 2017 - 21:42 EST
Monitoring
We had to take bhcp02.myhostcenter.com down for maintenance. We estimate to have the server back online by 11pm EST.
Thank you for your patience.
Posted 11 months ago. Jan 09, 2017 - 21:14 EST