Downgraded Performance
Incident Report for Hosting Servers & Network
Resolved
The emergency maintenance of cpanel05.myhostcenter.com is completed now. At this time all services are back up and running. If you are still experiencing any issues please contact our Support Department for further investigation.
Posted 6 days ago. May 19, 2017 - 01:31 EDT
Investigating
We are currently investigating downgraded performance with the following server: cpanel05.myhostcenter.com

We will update this post with all information pertaining to this issue. Thank you for your patience.
Posted 6 days ago. May 18, 2017 - 22:11 EDT